Post Reply 
 
Thread Rating:
  • 14 Vote(s) - 3.64 Average
  • 1
  • 2
  • 3
  • 4
  • 5
BMW E90 320I Cranking but NO START
29-04-2014, 06:44 PM
Post: #1
BMW E90 320I Cranking but NO START
Hello all,

One of my friend are having an issue with his 2005 BMW E90 320i with the N46 Valvetronic engine.

Car ran great untill it spung bearings due to and oil leak and faulty oil level sensor.

After redoing engine and assembling everything as it was (Timing included and lines up with home-made marks on how it was when he dissasembled it.

Double, Tripple checked a million times. All timing marks are correct and match to the workshop manual.

Problem is that the car only cranks but does not start at all. (Check engine light illuminated)

Checked the codes, and all that pops up is "Engine temp sensor...)
Tried adjusting the cam pulse sprockets in other directions (ALL WAYS)
all that does is give anothe code P1061 Variable valve timing, bank 1 - limp home mode - circuit malfunction. Adjusted the cams pulse sprockets back to factory possitions than only one error (ENGINE TEMP....) with no check engine light.

Checked, Fuel pump engauges when engine cranks, rulling out crank speed sensor?

Checked for loose connections & Checked engine earth

Checked the coils, NO SPARK ON ALL CYLINDERS? (Changed plugs aswell)
Could one error really disable everything?

Any help or recommendation welcomed.

Find all posts by this user
Like Post Quote this message in a reply
29-04-2014, 07:39 PM
Post: #2
RE: BMW E90 320I Cranking but NO START
Check Engine bay on the RHS (Drivers)

Next to the battery charge point, there is a smallish wire (pinky sized) that runs across the engine bay into the DME box in the top left.

Check for power on that wire using a multi meter.

If there is no power, in the boot, on top of the battery, there is a set of inline fuses, find the faulty one.

Or check the STK cable, Or bring me the car

and fuel pump cranking does not rule out crank sensor.

I will be on the other side if anybody needs me Bluebiggrin
Find all posts by this user
Like Post Quote this message in a reply
The following 1 user Likes zaleonardz's post:
Kish2604
30-04-2014, 06:09 PM
Post: #3
RE: BMW E90 320I Cranking but NO START
Hello All,

Checked all the wiring, all fine.
Connected DIS today, and noticed a error in the CAS (Car Access System)
ended up being the key not sending the right codes to the EWS.

Re-calibrated the KEY, Started Right up, BUT after "Check engine light illuminates" it dies and would NOT start-up again until engine code is cleared:
"Engine Temperature Sensor - Short Circuit or Open Circuit"
I do understand why the engine temp sensor would disable start (To protect engine?)

I also checked the status of the engine temp (0'C)
Checked Sensor connection as-well.

Anyone, Any Ideas?

Find all posts by this user
Like Post Quote this message in a reply
23-03-2016, 07:30 PM
Post: #4
RE: BMW E90 320I Cranking but NO START
(30-04-2014 06:09 PM)bmw328 Wrote:  Hello All,

Checked all the wiring, all fine.
Connected DIS today, and noticed a error in the CAS (Car Access System)
ended up being the key not sending the right codes to the EWS.

Re-calibrated the KEY, Started Right up, BUT after "Check engine light illuminates" it dies and would NOT start-up again until engine code is cleared:
"Engine Temperature Sensor - Short Circuit or Open Circuit"
I do understand why the engine temp sensor would disable start (To protect engine?)

I also checked the status of the engine temp (0'C)
Checked Sensor connection as-well.

Anyone, Any Ideas?

Hello! Did you solve the problem? I have the same car with the same issue and it drives me nuts.
Find all posts by this user
Like Post Quote this message in a reply
23-03-2016, 07:59 PM
Post: #5
RE: BMW E90 320I Cranking but NO START
(23-03-2016 07:30 PM)qnnis Wrote:  
(30-04-2014 06:09 PM)bmw328 Wrote:  Hello All,

Checked all the wiring, all fine.
Connected DIS today, and noticed a error in the CAS (Car Access System)
ended up being the key not sending the right codes to the EWS.

Re-calibrated the KEY, Started Right up, BUT after "Check engine light illuminates" it dies and would NOT start-up again until engine code is cleared:
"Engine Temperature Sensor - Short Circuit or Open Circuit"
I do understand why the engine temp sensor would disable start (To protect engine?)

I also checked the status of the engine temp (0'C)
Checked Sensor connection as-well.

Anyone, Any Ideas?

Hello! Did you solve the problem? I have the same car with the same issue and it drives me nuts.

What's the exact issue you having? Most of these issues are related to the ecu getting wet and thus failing.

Find all posts by this user
Like Post Quote this message in a reply
24-03-2016, 07:26 AM
Post: #6
RE: BMW E90 320I Cranking but NO START
(23-03-2016 07:59 PM)Ratslaaf@OBDWorx Wrote:  
(23-03-2016 07:30 PM)qnnis Wrote:  
(30-04-2014 06:09 PM)bmw328 Wrote:  Hello All,

Checked all the wiring, all fine.
Connected DIS today, and noticed a error in the CAS (Car Access System)
ended up being the key not sending the right codes to the EWS.

Re-calibrated the KEY, Started Right up, BUT after "Check engine light illuminates" it dies and would NOT start-up again until engine code is cleared:
"Engine Temperature Sensor - Short Circuit or Open Circuit"
I do understand why the engine temp sensor would disable start (To protect engine?)

I also checked the status of the engine temp (0'C)
Checked Sensor connection as-well.

Anyone, Any Ideas?

Hello! Did you solve the problem? I have the same car with the same issue and it drives me nuts.

What's the exact issue you having? Most of these issues are related to the ecu getting wet and thus failing.

Engine Temperature Sensor - Short Circuit or Open Circuit error and engine cranks but not starting.
Find all posts by this user
Like Post Quote this message in a reply
24-03-2016, 07:45 AM
Post: #7
RE: BMW E90 320I Cranking but NO START
I'm pretty sure that won't prevent the car from starting hey.

Find all posts by this user
Like Post Quote this message in a reply
24-03-2016, 08:14 AM
Post: #8
RE: BMW E90 320I Cranking but NO START
Off course this isn't the cause, but i think that is related to the problem.
Today i will test some signals and power supply to DME (ECU).
Find all posts by this user
Like Post Quote this message in a reply
24-03-2016, 09:58 AM
Post: #9
RE: BMW E90 320I Cranking but NO START
Please, I need help!
Find all posts by this user
Like Post Quote this message in a reply
24-03-2016, 07:14 PM (This post was last modified: 24-03-2016 07:14 PM by Ratslaaf.)
Post: #10
RE: BMW E90 320I Cranking but NO START
Where you based buddy? Just open the ebox and check for signs of water


Find all posts by this user
Like Post Quote this message in a reply
12-10-2017, 10:47 AM
Post: #11
RE: BMW E90 320I Cranking but NO START
Hi all.
I seem to be having a similar problem on my E90 323i.Car would not start after standing for a few days because of a failing battery.Replaced battery now it only cranks but won't start.No codes on the scan tool,fuel pump is running but there is no spark.
Find all posts by this user
Like Post Quote this message in a reply
12-10-2017, 11:06 AM
Post: #12
RE: BMW E90 320I Cranking but NO START
Starter Maybe?

Current: 2001 BMW E46 330i
Find all posts by this user
Like Post Quote this message in a reply
12-10-2017, 01:24 PM
Post: #13
RE: BMW E90 320I Cranking but NO START
(12-10-2017 10:47 AM)Tony323i Wrote:  Hi all.
I seem to be having a similar problem on my E90 323i.Car would not start after standing for a few days because of a failing battery.Replaced battery now it only cranks but won't start.No codes on the scan tool,fuel pump is running but there is no spark.

Welcome.

If you've had more than 10 failed starts, you need to have the dme counter reset.
The DME specialist guys can help you out.

I've walked the walk...
Now I talk the talk...
Find all posts by this user
Like Post Quote this message in a reply
12-10-2017, 08:14 PM
Post: #14
RE: BMW E90 320I Cranking but NO START
(12-10-2017 01:24 PM)husaindindar Wrote:  
(12-10-2017 10:47 AM)Tony323i Wrote:  Hi all.
I seem to be having a similar problem on my E90 323i.Car would not start after standing for a few days because of a failing battery.Replaced battery now it only cranks but won't start.No codes on the scan tool,fuel pump is running but there is no spark.

Welcome.

If you've had more than 10 failed starts, you need to have the dme counter reset.
The DME specialist guys can help you out.

That depends on the car. PreFL N52 up to '07 that would be the case. From around April '07 there's no more rolling code so won't go out of sync.

And if ecu is dead, you won't see any codes. To check if ecu is communicating, check if rev counter hovers around 300rpm when cranking. If not, then you know where to start looking.

Find all posts by this user
Like Post Quote this message in a reply
The following 1 user Likes Ratslaaf's post:
husaindindar
Yesterday, 03:45 PM
Post: #15
RE: BMW E90 320I Cranking but NO START
Realign cas/dme

Sent from my SM-N9005 using Tapatalk
Find all posts by this user
Like Post Quote this message in a reply
Post Reply 




User(s) browsing this thread:
1 Guest(s)

Return to TopReturn to Content